Ford Kuga Owners Club Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Good afternoon all,
Got the machine, 3 days ago, and problems are flooding in....

- Water in the fuse box, (air cond. condensation) indicators keep on running engine stopped!!!

- No cruise control after 200Km (could be related to water in fuse box)

- High pitch whissle above 110KPH, (70MPH)

- Chrome trim from bonnet coming off.

- Dead pixel on the 7" GPS

- bonnet loose

all of that within 1000Km not bad going!!!

Not impressed for the first Ford I buy.... ~‚¬ 37000 with all options.



If any one has solutions to these problems, they will be welcome.

I have NO confidence in garages. I tend to sort out problems myself, as they do more damage than fixing most of the time.



Thanks

Fred
 

·
Registered
Joined
·
1,079 Posts
Hi there fredvr. I was quite surprised to read your thread when you first posted, because almost all of the other feedback from new owners on this forum is full of praise for their Kugas. I suppose not every car can be perfect, but it seems that you had more than your share of problems. Has everything been sorted out now? Most owners here are UK based and have RHD, maybe something in the LHD version makes it more likely to flood? I live in Spain, and had my LHD Kuga delivered mid July. I didn´t yet get it 'properly' wet!

Was the warranty cover and service good enough? It would be interesting to hear if you are happier with your choice of car now.

Hope things have got better anyway.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Hi Quatroxquatro, the fuse box problem has been sorted out, they did not change the box though so I am pretty pi....d off with Ford, theykept the car for 1 week just to reset the cruise control!!!. They is still the whisling noise come from according to them the front grill which has been on order for 2 weeks. The aftersale was OK, but not very agreable people. Ford assistance on the other hand were BRILLIANT.
I am impressed with the overall impression of the Kuga, Today I went in an X3 then X5 BMW, honnestly, they are not worth it. The X3 is really poor ride, noisy, unconfortable. The X5 ressembles a whale and fells like one.



Anyway still waiting for the front grill to reduce that noise from 80KmH on.

Fred.
 

·
Registered
Joined
·
63 Posts
Re the loose chrome bonnet trim- I've heard that it's fixed on with 2 bolts and double-sided sticky tape (I haven't checked this myself).
However some cars left the factory without the backing tape being peeled off the double-sided tape, so no adhesion (apart from the 2 bolts), resulting in the whistling noise at speed.
 
1 - 5 of 5 Posts
Top