Ford Kuga Owners Club Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter · #1 ·
Has anybody got the tyre pressure monitor system and had problems?


I have today had my K serviced for 1st time and requested the dealer repair the tyre pressure monitor as it had stopped working. Checked when I collected the car but system could not be fixed despite all their efforts.

I enquired what was to be done but they could not give an answer only to say they had called Ford and suggested it was a software fault that Ford would need to fix but could not offer any idea when this might happen.



I will be contacting Ford Customer service tommorrow and will keep information updated on this but if anybody else has experienced this could you post a reply

Thanks
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #2 ·
Just an update for anybody interested


Contacted Ford customer services and they could not have been more helpfull. They rang my dealer and spoke directly to the service technician to establish the full picture. They have given me an incident number and explained that there is a software update due out very shortly which is hoped will fix the issue. Thet have promised to contact me in a week to update me with the situation.



As there has been no responseI assume that there are few others out there with the system or nobody has had a problem with theirs. System was on the demonstrator K I purchased at 5 months old but is probably not high on spec. requirements for many purchasers.



Will post updates as as we progress
 

·
Premium Member
Joined
·
2,975 Posts
I have the Tyre Deflation System fitted to mine but apart from setting the current tyre pressure via the info center I've never noticed the system either working or having a problem so I assumed it was working fine and the tyre pressure remained as per the first setting.

Out of interest how did you know it had stopped working?
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #4 ·
Hi Gazwats

Not certain why I checked only to find it not working. Like you never had any indication that it was or not working from first setting it up. Good to know somebody else has the system and it is working. Hope my agents and Ford can sort it out. Will keep the thread updated with progress
 

·
Premium Member
Joined
·
2,975 Posts
Thanks for the update LT.

You've got me thinking as whether mine's working or not now, I think I might just release a bit of air out of one of them to see if it flags up any warning message in the info centre.
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #6 ·
Update for anybody with issues on Tyre pressure monitoring system
My agent had the car again yesterday on called in a roving Specialist direct from Ford. Pleased to say he has now fixed the system and it now works. I could not get any further explanation other than it involevd an update / Reprogram to the electronics and all is well.

Just a further note Ford Customer service shave been most supportive through out this issue and I would like to record my thanks to them for their exchanges with the dealers and myself to ensure I was satisfied

Gazwats Hope you found yours to be functioning OK but I will be keeping a close eye on it in the future.
 
1 - 6 of 6 Posts
Top