Ford Kuga Owners Club Forums banner
21 - 34 of 34 Posts

·
Registered
Ford kuga 2014 2.0 180hp AWD
Joined
·
18 Posts
When was the gearbox last serviced.
Hi @ smartguy69 , we had discussion on this on a different thread weeks back as the Ford dealer have quoted £830 for oil change , diesel air and oil filter change + transmission fluid change . However I have found a local garage and have planned to change all these on 18/05/2022 that’s in 4 days .
 

·
Registered
Joined
·
1,834 Posts
Did the BMS get reset when the new battery was fitted.
Also I'm not sure on the UK spec cars, but over here the 180bhp version didn't come out until 2015.
 

·
Super Moderator and Mr Grumpy
Joined
·
9,693 Posts
Did the BMS get reset when the new battery was fitted.
Also I'm not sure on the UK spec cars, but over here the 180bhp version didn't come out until 2015.
Euro 6 diesel engine with the 150/180 was introduced here last quarter of 2014.
 

·
Registered
2013 Titanium X with 2017 Powershift Conversion.
Joined
·
2,233 Posts
Looks like they fitted an engine wiring harness last time round.

Ideally you need to have the fault codes read from gearbox TCU and engine PCM.

It "should" have the later gearbox which is a better design, what mileage is on it?.
 

·
Registered
2013 Titanium X with 2017 Powershift Conversion.
Joined
·
2,233 Posts
Ask garage to pull any fault codes when it goes in for service and make sure they know how to set the level correctly as it's not like a normal gearbox.

If they just pull the level plug at the end it will be underfilled.
 

·
Registered
Ford kuga 2014 2.0 180hp AWD
Joined
·
18 Posts
Ask garage to pull any fault codes when it goes in for service and make sure they know how to set the level correctly as it's not like a normal gearbox.

If they just pull the level plug at the end it will be underfilled.
Thank you @keithmac for giving me that information so that I can pass this to the garage people .
 

·
Registered
Ford kuga 2014 2.0 180hp AWD
Joined
·
18 Posts
Dear friends , I got my car serviced today , got the transmission oil and filter changed too. They told the transmission oil looked filthy ! The mechanic told me that the diagnostics showed issue with the EGR valve / sensor and it was just dangling than being plugged in completely !! So all he did was he pushed it in until it clicked and the issue has been solved . I don’t have much knowledge about this but this is what he told me . I have attached a pic of the diagnostic paper too . There’s no warning light on the dash and gear changes swiftly . A big Thank you to all you guys for running this forum as it’s of massive help and especially smartguy69 & keithmac - you guys don’t have a clue how immensely helpful you guys suggestions are for people with little knowledge on cars like me is . Thanks a ton .
 

Attachments

21 - 34 of 34 Posts
Top