Ford Kuga Owners Club Forums banner

21 - 37 of 37 Posts

·
Registered
Joined
·
44 Posts
Ripperoo, Just checked mine and it is set correctly to mph under Road sign recognition. I can only find the one place to change measurements/units so your situation is very confusing.
 

·
Registered
Joined
·
790 Posts
......your situation is very confusing.
But not unheard of as I have found out on a couple of forums.

Just been for a 15 mile round trip for "provisions" and the speed alerts were still stuck on km/h.

I read on a forum that setting a destination on the nav can sort it out, so did that (even tho I knew where I was going) and low and behold, on checking again, the speed alerts had changed to mph and traffic signs were flashing when they should. WTAF?

So popped in store for those "provisions" and on my return journey, it started being a dick again.

Then all of a sudden it came right again.

What a POS!

Buyers remorse? You betcha!
 

·
Registered
Joined
·
2,774 Posts
There's way too much tech being added into vehicles that hasn't had time to "mature" before being fitted. (All IMHO of course!) I deliberately didn't order the optional package that included the Active City Stop, Blind Spot, Sign reading, ACC etc. For the extra money I didn't think it was worth it.



PS: I love the latest pedestrian protection with cars auto braking to a complete stop- car jackers are going to love that feature!
 

·
Registered
Joined
·
1,742 Posts
There 3 settings.
First one is confusing tho.

1. 0-0
2. 0-5
3. 5-10

Just back from dropping granddaughter of at nursery and tried the speed warning. Flashed at 35-36.
 

·
Registered
Joined
·
790 Posts
Well, mine has started playing up again.sad:

Started a few days ago and I've tried the usual fix of choosing a destination on the SatNav, which normally sorts out the display being stuck on KMH despite everything else (odometer, trip etc) being in MPH.

The display settings are showing KMH again and are not user changeable, so hoping it goes back MPH once the time of the month is over (Big Red must be on the blob).

It started a few days before it was booked into the dealer for the fuel economy issue and even they couldn't sort it, so feck knows when or if it will sort itself out.
 

·
Registered
Joined
·
23 Posts
Hi all, just latching onto this thread slightly, my 18 plate ST Line X doesn't have traffic sign recognition is this a factory option only only or can it be fitted later?
 

·
Registered
Joined
·
790 Posts
I have it on mine and the housing behind the rear view mirror contains the camera reeded to see the road side cameras. I very much doubt the necessary hardware will be fitted by default and if that is the case reckon retrofitting the traffic sign recognition (part of the Driver Assistance Pack) would be quite expensive if even possible.

But if the hardware is in fact already installed (but dormant), then it MAY be possible to activate it via "Forscan".

Seems a guy from Austria did this in his Focus who says the hardware is installed (not sure if he self-fitted or it was factory fitted though).
https://forscan.org/forum/viewtopic.php?t=6149

However, he was asking for advice on codes to activate it via "Forscan".

You may have to do a bit of digging.
 

·
Registered
Joined
·
23 Posts
Thanks for the reply ripperoo, its not a major issue if it's not possible I'll investigate further, my previous kuga a titanium Xsport had it and was useful aswell as the blind spot warning on the door mirrors, these are good safety options they should be std on all variants just my opinion
 

·
Registered
Joined
·
44 Posts
Just to add to this, my lane guidance system is always peculiar tugging me off the road and all sorts and the traffic sign recognition (set to flash when 20 over the limit) just flashes whenever it wants ! According to the dealer, the lane guidance system "only works on motorways" and the traffic sign recognition has "known glitches" - definitely wouldn't pay the £500 option again, complete waste of cash!
 

·
Registered
Joined
·
44 Posts
Maybe the lane keeping notices you are 20mph over the limit and is telling you it would be safer if you got off the road ????
 

·
Registered
Joined
·
2,731 Posts
Lane guidance works on all roads and is governed by the lane markings, I find it annoying on normal roads and only switch it on on DCs and MWs
 

·
Registered
Joined
·
2 Posts
I have the same problem: Kuga spots the speed limit signs perfectly, but flashes as a warning almost continuously, as it clearly reads the number on the sign but thinks it is kmh. I've tried setting a destination in the satnav, but no change. I've tried turning sign recognition off and on again: no change. I can't see where to change measurement from km to miles - the only 'measurement unit' I can find is to change between mpg and l/km for the fuel consumption (and I tried that, anyway).

Mine's under warranty for a few months yet; think Henry will fix it for me?
 

·
Registered
Joined
·
1,742 Posts
It’s in the car settings under units. Mph kph. Click mph and exit.
 
  • Like
Reactions: smartguy69

·
Registered
Joined
·
2 Posts
Hi, Psshaw - thanks for the quick response. Tried it this morning. I can't find 'Units' setting anywhere, and it's definitely not under 'Vehicle Settings' (on the dashboard settings). The only units I can change are the mpg. Page 78 of my manual says I can go to a menu called 'Measure Units', but doesn't tell me how to get there. If I could, I should press 'OK' and it will swop.
Eventually under the SYNC screen 'general Settings' I found where I could change from miles to km (and also Celsius to Fahrenheit), so I changed it to km there. The digital speed display changed immediately; the Sign stayed in mph, and the Sign still flashed whenever I went over the '30' in kph. Changed it back to 'miles', the digital readout changed, but the sign still flashes whenever the speed was exceeded in kph. Tried setting a destination - no success. I resigned myself to leaving it to a dealer.

Then went out this afternoon, and it works perfectly... Weird.

Thanks for your help.
 

·
Registered
Joined
·
1,742 Posts
No probs, that’s why we are here, to help each other.
 

·
Registered
Joined
·
683 Posts
Have you looked at the Sat Nav and make sure the language is in English, which will then give you mph and count down on sat nav is also in Imperial.
Just a thought?
 

·
Registered
ST-Line Edition
Joined
·
275 Posts
I also have this display in KPH, even though everything is set to MPH.
 
21 - 37 of 37 Posts
Top