Ford Kuga Owners Club Forums banner
1 - 19 of 19 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello, recently I updated my SYNC 3 v2.3 to v3, and my system has started to lag(very slow to respond.)
Is there any chance to revert update back to v2.3 or any other fix ?
Model - Ford Kuga-Vignale 2018
Already did soft reset and master reset.
 

·
Registered
Joined
·
291 Posts
Have you got the new update V3.0 Map f9 and BUILD 20204?
Build 20204 was released last week.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Have you got the new update V3.0 Map f9 and BUILD 20204?
Build 20204 was released last week.
Yes, that's the one I updated.
The funny thing is, with master reset you cant even revert back, and my ford owners account, says that the system is up to date, so I cant get back the previous update.
 

·
Registered
Joined
·
523 Posts
It can be laggy for a while after updates - a bit of tidying up going on in the background I presume. Should sort itself out.
 

·
Mr. Forgetful
ST-Line Edition 2019 AWD - Petrol - Auto
Joined
·
1,263 Posts
Give it some time first, as @Gregs24 says (y)
 

·
Registered
2017 Frozen White Titanium manual 2wd 150 appearance pack, Sync 3.4
Joined
·
48 Posts
Hello, recently I updated my SYNC 3 v2.3 to v3, and my system has started to lag(very slow to respond.)
Is there any chance to revert update back to v2.3 or any other fix ?
Model - Ford Kuga-Vignale 2018
Already did soft reset and master reset.
[/QUOTE
 

·
Registered
Joined
·
1,136 Posts
You cannot go back with conventional means, I doubt that even your local Ford shop would be able to do this, you'll either have to visit a main dealer/service, or resort to some XDA or GPSnet thread to find a way to do it.

The master reset just clears up the system's cache, i.e. deletes files from the previous installation/update.
 

·
Super Moderator and Mr Grumpy
Joined
·
5,798 Posts
Slightly of topic....did you have snow today in Greece @The Ace
 

·
Registered
Joined
·
1,136 Posts
Yeap, mild snowing last night even inside Athens, and more heavy snowfall right now...everything should be blanketed come tomorrow morning...
 

·
Super Moderator and Mr Grumpy
Joined
·
5,798 Posts
Saw it on the news today. I didn't think you had snow there.
 
  • Like
Reactions: Phil Doggo

·
Update Ninja
Vignale 2019, Platinum White
Joined
·
3,530 Posts
Yeap, mild snowing last night even inside Athens, and more heavy snowfall right now...everything should be blanketed come tomorrow morning...
Better get the winters on Anthony
 

·
Super Moderator and Mr Grumpy
Joined
·
5,798 Posts
Oh no what have I started. I feel a winter tyre debate coming on.

Hopefully with a slight digression it will have given enough time for the OP's sync 3 to have properly updated itself.
 

·
Registered
Joined
·
1,136 Posts
Better get the winters on Anthony
I knew I should've gotten the CrossClimates back in September :D

Athens is almost in a standstill, winters or chains even in the center (Syntagma), the two main highways towards Thessaloniki kai Patra are closed, Civil Protection has issued warnings about restricting traffic and closing main roads, this is a once-every-20-years situation. Same deal all over Greece, northeners are coping much better than us, we're not used to heavy snow after all....
 

·
Super Moderator and Mr Grumpy
Joined
·
5,798 Posts
If you have some mountains then Greece could become the next popular ski resort. Subject to travel restrictions of course.
 

·
Registered
Joined
·
3 Posts
Hi, just to let you know I also last week downloaded and installed V3.0 20204 and have the same problem as you. Everything lags so much it's unusable. From what I've read this is a fairly new update so I wonder if this problem is going to show it's head as the days/weeks go on. My car (2017) has been running for over 2 hours twice since the update so it should have sorted it out by now.
When you get in it seems ok but very soon after each button press it's gets slower until it's so slow you think it's locked up.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #16 ·
Hi, just to let you know I also last week downloaded and installed V3.0 20204 and have the same problem as you. Everything lags so much it's unusable. From what I've read this is a fairly new update so I wonder if this problem is going to show it's head as the days/weeks go on. My car (2017) has been running for over 2 hours twice since the update so it should have sorted it out by now.
When you get in it seems ok but very soon after each button press it's gets slower until it's so slow you think it's locked up.
Yeah, t'hats exactly my case.
I found out one more thing - Yesterday I put the usb (with the same update) back in and as the system update process started again, it started to work normal, today morning I started the car, and the lag is back. 🤯
 

·
Registered
Ford Kuga 2018 ST Line X Magnetic Grey
Joined
·
110 Posts
What did the update actually do?
 

·
Registered
Joined
·
1 Posts
Yeah, t'hats exactly my case.
I found out one more thing - Yesterday I put the usb (with the same update) back in and as the system update process started again, it started to work normal, today morning I started the car, and the lag is back. 🤯
That's exactly my case also. Have anyone solved this? When I put the USB back in, it starts to work normal. Next time I start car without USB and the lag is back again.
 
1 - 19 of 19 Posts
Top