Ford Kuga Owners Club Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
929 Posts
Discussion Starter #1
If like me you decide to get the beast serviced before the 12,500 mileage interval, please note the 'Service Oil' message comes up on the display.


Ford do not reset this at the service, as they have to wait for it to come on.



Proceedure for reseting the message.



1. Turn on ignition but do not start the vehicle.

2. Depress the Brake pedal and accelarate to the floor.

3. Keep depressed for approx 20 seconds.

4. Message displays reset Service Oil Service.

5. Turn ignition off.

6. Turn ignition back on and system all reset.



I hope this is of some use.
 

·
Registered
Joined
·
79 Posts
Hi Stupot

Many thanks for this info

Had my service carried out last week a few hundred miles before 12.5 K.

This week Service Oil indicator came on.

Remembered seeing this post and carried out the procedure this morning.

Saved a call to the dealer to reset.

Thanks
 

·
Registered
Joined
·
929 Posts
Discussion Starter #3
You welcomed Kuga4wd


Its nice to know that info on this site is useful and helps others in the same situation.
 

·
Registered
Joined
·
29 Posts
Nice one Stupot. Mine has just come on but isn't in for a service til next week, so thanks for the info
 

·
Registered
Joined
·
1,024 Posts
Mine too, thanks Stupotfor the info-it was very easy to sort out with your instructions.
Took less thatn 30 seconds.



Before I saw you post, I had rung my dealer and they said to bring it in and they could reset it in about ten minutes. Why didn't they just tell me to do exactly what Stupot has? It would save their time and mine.
 
1 - 5 of 5 Posts
Top