Ford Kuga Owners Club Forums banner
1 - 11 of 11 Posts

·
Registered
2009 tdci 2.0ltr
Joined
·
8 Posts
Discussion Starter · #1 ·
Hello
Can anyone give me advice on this please? Drivers side engine mount has rust deposits on, and around it. (it has "sprayed" the rust colour around the mount)
Doesn't appear to be an issue with the mount, no vibrations or noise.

Does it need replacing or is this a common problem?

Thanks in advance for your advice.
Wood Automotive tire Automotive wheel system Wood stain Hardwood

Motor vehicle Automotive tire Gas Vehicle Electrical wiring
 

·
Registered
Joined
·
1,638 Posts
Looking at the cracks in the rubber, I would change that.
They can't be very expensive.
 

·
Mr Modification
Ford Kuga MK2 16/12/2014 Titanium X Sport AWD 2.0TDCI 182PS 400Nm (T8MA) Manual Sync1
Joined
·
623 Posts
This colour looks like dried out coolant. Did you have coolant leaks in the past or notice any lack of coolant?

This rubber on it its little tired but not seriously cracked. Inside is oil so when it definitely fault you may see oil leak from it.
This engine mount will cost about 70£ over. Depending of brand. Fairly easy to change.
 
  • Like
Reactions: Tandy2000

·
Registered
2009 tdci 2.0ltr
Joined
·
8 Posts
Discussion Starter · #4 ·
This colour looks like dried out coolant. Did you have coolant leaks in the past or notice any lack of coolant?

This rubber on it its little tired but not seriously cracked. Inside is oil so when it definitely fault you may see oil leak from it.
This engine mount will cost about 70£ over. Depending of brand. Fairly easy to change.
No coolant leaks. Coolant is very slightly down from last time I checked (which was a couple of months ago)
 

·
Registered
2009 tdci 2.0ltr
Joined
·
8 Posts
Discussion Starter · #5 ·
No coolant leaks. Coolant is very slightly down from last time I checked (which was a couple of months ago)
Just googled does coolant look rusty when dry, and it does look just like coolant has dried! Maybe some has escaped from the cap perhaps, but there isnt a leak and the header tank is clear, and the coolant perfectly pinky/red.... hmmmm What has happened!?
 

·
Registered
Joined
·
63 Posts
It's coolant. The cap has vented pressure. It's either:-

Been overfilled in the past and vented.
Had a fault in the past that's caused it to vent.
Got a cooling system fault now.

Nothing wrong with the engine mount.
 

·
Registered
2009 tdci 2.0ltr
Joined
·
8 Posts
Discussion Starter · #7 ·
It's coolant. The cap has vented pressure. It's either:-

Been overfilled in the past and vented.
Had a fault in the past that's caused it to vent.
Got a cooling system fault now.

Nothing wrong with the engine mount.
What on earth would cause a cooling system fault like that?
 

·
Registered
2009 tdci 2.0ltr
Joined
·
8 Posts
Discussion Starter · #9 ·
I'm worried because those things are suggestions of a potential head gasket issue and that is expensive.
However the coolant is still the correct colour and it doesn't and hasnt over heated
Your question makes it sound like this is an outlandish suggestion. Any fault that causes an excess of pressure would do this. Eg. Lack of flow, combustion gasses in coolant etc etc.
I'm worried because those things are suggestions of a potential head gasket issue and that is expensive.
However the coolant is still the correct colour and it doesn't and hasnt over heated
.
 

·
Premium Member
Kuga ST Line X 1.5 Eco 180ps 6 Speed Auto AWD Magnetic
Joined
·
785 Posts
Get a wire brush, clean it off, spray a bit of black paint on it and see if it happens again
Like the others that looks like escaped coolant to me as well 😎
 

·
Registered
Joined
·
11 Posts
As above, just clean it all off for now and see what's what. Would be reasonably rare for a head problem these have steel gaskets.

Is a bit bizarre it's a rusty colour as this red coolant when I've splashed some about over the years, it turns into a bit of a chalky dust as it's dried out.
 
1 - 11 of 11 Posts
Top