Ford Kuga Owners Club Forums banner

1 - 7 of 7 Posts

·
Registered
Ford Kuga 2008 (58) 2.0 TDCI Titanium 4x4
Joined
·
23 Posts
Discussion Starter #1
I had an issue with my rain sensor but that was just due to the contact with the windscreen.

Now I'm getting the fault code:

U2030 - Rain Sensor Communication Fault
Module: Generic Electronic Module

I have tried another working rain sensor and this fault code still shows up, what could the problem be and what do i need to check?
 

·
Registered
Joined
·
3,566 Posts
Have you checked the carpets on the front passenger side. The MK1 was prone for water leaks on the bulkhead right above the fusebox. That would be my first check.
 

·
Registered
Joined
·
439 Posts
Possibly a damaged connection from doing the replacement?

Bob
 

·
Registered
Ford Kuga 2008 (58) 2.0 TDCI Titanium 4x4
Joined
·
23 Posts
Discussion Starter #4
Have you checked the carpets on the front passenger side. The MK1 was prone for water leaks on the bulkhead right above the fusebox. That would be my first check.
The carpets are wet but that must be coming from the floor panels because I took the fuse box out completely to check and it doesn't look wet at all.
 

·
Registered
Ford Kuga 2008 (58) 2.0 TDCI Titanium 4x4
Joined
·
23 Posts
Discussion Starter #5
Possibly a damaged connection from doing the replacement?

Bob
It could be but I'm not sure how to check that, it looks fine but it would be good if I could find out where the wires go and check there is continuity.
 

·
Registered
Ford Kuga 2008 (58) 2.0 TDCI Titanium 4x4
Joined
·
23 Posts
Discussion Starter #6
Does anyone have a wiring diagram i can have a look at so I know where the wires go?. Am I correct in thinking that it's a LINBUS so the three wires are Ground, 12V and Lin Data ?
 

·
Registered
Ford Kuga 2008 (58) 2.0 TDCI Titanium 4x4
Joined
·
23 Posts
Discussion Starter #7
I ended up sorting this in my other thread:

 
1 - 7 of 7 Posts
Top