Ford Kuga Owners Club Forums banner
1 - 10 of 10 Posts

·
Registered
2017 Ford Kuga Titanium X AWD Diesel 2.0
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi I have a 2017 Kuga titanium x, which over the last 2/3yrs randomly cuts at whilst im stopped ( waiting to pull out of a road etc) no pre warning, no warning lights, all the dash is still lit, just the power goes off, it’s an automatic so I just put it back into park and hit the stop/start button and it comes back on. It has been in a garage for a few days and they couldn’t find anything wrong with it. I’ve also noticed it reves up after when I park for a minute or so then goes back to normal. Any ideas or suggestions as seriously considering changing it, thank you
 

·
Registered
69 plate Kuga ST line edition in Ruby Red, 2.0 AWD diesel Manual 180bhp
Joined
·
114 Posts
Hi I have a 2017 Kuga titanium x, which over the last 2/3yrs randomly cuts at whilst im stopped ( waiting to pull out of a road etc) no pre warning, no warning lights, all the dash is still lit, just the power goes off, it’s an automatic so I just put it back into park and hit the stop/start button and it comes back on. It has been in a garage for a few days and they couldn’t find anything wrong with it. I’ve also noticed it reves up after when I park for a minute or so then goes back to normal. Any ideas or suggestions as seriously considering changing it, thank you
You sure it's not the stop/start feature?
 

·
Registered
2013 Titanium X with 2017 Powershift Conversion.
Joined
·
1,820 Posts
Does sound remarkably like Stop-Start function as said above.
 

·
Moderator
2016 Kuga Titanium 2.0l EcoBoost
Joined
·
3,506 Posts
Has it been scanned for fault codes with a Ford medium speed CANBus compatible reader? (e.g. using a program like ForScan.)
 

·
Registered
Joined
·
2 Posts
Hi I have a 2017 Kuga titanium x, which over the last 2/3yrs randomly cuts at whilst im stopped ( waiting to pull out of a road etc) no pre warning, no warning lights, all the dash is still lit, just the power goes off, it’s an automatic so I just put it back into park and hit the stop/start button and it comes back on. It has been in a garage for a few days and they couldn’t find anything wrong with it. I’ve also noticed it reves up after when I park for a minute or so then goes back to normal. Any ideas or suggestions as seriously considering changing it, thank you
I have the same Kuga with the same problem, I assumed it was the stop/start, but the instructions on how to start it again are not in the manual. Does anyone know the proper procedure to start it again?.
 

·
Registered
South Wales 🏴󠁧󠁢󠁷󠁬󠁳󠁿
Joined
·
1,485 Posts

·
Registered
South Wales 🏴󠁧󠁢󠁷󠁬󠁳󠁿
Joined
·
1,485 Posts
or read this post

 

·
Registered
South Wales 🏴󠁧󠁢󠁷󠁬󠁳󠁿
Joined
·
1,485 Posts
I downloaded a version on the manual ( the one I put the link to) and put it on my iPhone,so it’s always with me,,also it’s on my iPad .
 
1 - 10 of 10 Posts
Top