Ford Kuga Owners Club Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter · #1 ·
Day 15 from brand spanking new and I got this message and no satnav. Stopping and restarting made no difference. Nav was working fine driving to Leamington, and from the office to the 'Frankie and Benny' burger rip-off for lunch. When I came out I got the above message and drove home without Navigation. I noticed that Mobile Apps was saying that nothing was available though it was reporting the phone as linked and displaying it's battery state. Just short of home I stopped at Tesco for some milk and cat litter. When I came out the satnav was working again.

I can see reports of this fault on Google from a couple of years ago but nothing recent so:
Frankie & Benny is sited on an estate consisting mainly of car showrooms, could it have been a GPS deadspot?
Is Nav so prone to dropping out that no-one reports it now?
Was the cat litter replenishment sufficient to kickstart the satnav?
As it says on the tin, 2018 2.0 Titanium X, Sync 3, two weeks old. Motability car from Bristal Street Motors.

Anyone have any ideas, suggestions?
 

·
Registered
Joined
·
6,754 Posts
I'd see if happens again but there could have been some interference across the satellite frequency as there is so many devices around in and outside a car that do not meet EMC standards, but particularly in cars and not necessarily your car. However, I'd expect yours to start working again once you had moved from the source of interference, without having to stop the engine etc.
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #3 ·
Now that's what got me, a conventional satnav would come to life and start displaying a map as soon as it got sight of a clean satellite signal but this seemed to need a complete shutdown to reset itself. To me, that says software that isn't resilient. A Google snoop revealed that it seems there's a Sync update available for my car, that's a bit bad after just two weeks! My old Tomtom Rider chugged along quite happily for the last 5ish years without any updates applied. I smell Microsoft influences. All I can say is, I'm glad I upgraded my phone to one with a decent sized display ready to take over as a satnav if Sync3 goes on the blink again.
 

·
Registered
Joined
·
6,754 Posts
Well if there is talk of an update, then there may be your problem.


Not surprising that its come requiring an update, Ford are so laid back they in danger of falling over.
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #6 ·
Nice to know that I'm not alone, lost maybe, but not alone!
 

·
Registered
Joined
·
1,153 Posts
Funny thing, the exact same thing happened to my brand new Kuga (less than 3K km in 6 months), when I went to start it up after leaving the beach. The car was under direct sunlight for about 4 hours, don't know if that had anything to do with the fault. Message was Navigation not Available (or Functioning), and lasted until the next startup, when all was fine. Haven't seen it since, will mention it to the dealer though...
 

·
Registered
Joined
·
304 Posts
Few months ago I was parking overnight in an underground carp park. Every morning about ten mins into drive lost GPS signal. Only way to get it back was to stop turn off and restart. Was almost like once it lost signal it gave up searching till it was reset.
 

·
Super Moderator
Joined
·
2,605 Posts
My Sync 3 'froze' trying to pair my phone after a week of not having an issue. Only a 'full reset' cured the issue.


If your unit is showing update available you can either do this over wifi at home or have a real 'piss and moan' at the dealer as they should have checked the release level as part of the PDI
 

·
Registered
Joined
·
2 Posts
Just had a call from 'the Mrs'. Her Kuga is displaying a "navigation not functioning" message this morning. She has stopped and restarted but still no good. Car is about 18 months old and I applied a Sync update about 2 weeks ago
 

·
Registered
Joined
·
1,605 Posts
Go for a full Sync reset, remove fuse 67 in the fuse box behind the glovebox, replace after a couple of minutes, hopefully it resets the Nav.
 
1 - 12 of 12 Posts
Top