Ford Kuga Owners Club Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi fellow Kuga owners.
I have had my Titanium now for exactly 6 months and apart from a minor irritation with the screen wash not covering all the windscreen, I thankfully have no problems with the number of issues we see in the forum from fellow owners, lucky me!

That said, I now have noticed a couple of times last month that the clock is loosing time. Not just loosing time, but also missing days! Despite resetting the time and date, I find a few days later that both are wrong again. I don't use my car every day but would not expect a drain on the battery sufficient to affect the time and date! No problem with starting although the lights remain on auto at all times which I would not expect to drain the battery? I know from buying car radios, that certain FM stations (BEEB for example) send time signals to the radio tocorrect any loss or gain, this I take it is not the case for the Sony? I have also noticed that by changing the time on the radio also changes the display on the messaging dash.

Anyone else noticed that the time and date need resetting on aregular basis?
 

·
Registered
Joined
·
11 Posts
I can add a me too! to this thread :eek:)
I have been very fortunate in that my Kuga has had very little wrong with it and I am very happy with it but every now and again I get in and look at the clock/date and have do to a double take before I reset it to the correct one. I can't figure out what is causing it and to be honest as it doesn't happen all the time I haven't mentioned it.....

I'll try to track what happens just before it goes again and let you know.
 

·
Registered
Joined
·
106 Posts
Yep same as mine this is the only fault i have had on my Kuga july 08 car Ford have no idea what the problem is they are in contact with Sony.
 

·
Registered
Joined
·
212 Posts
Yes I also have Sony radio,collected myKUGAJuly 08 unsure actually when built.


However it is a real pain anda regular weekly chore withthe clocklosing 1 or 2 mins per week.
 

·
Premium Member
Joined
·
2,975 Posts
My Zetec just has the standard Ford radio unit and I happened to notice for the first time last week that the time on the radio had lost 5 minutes since I picked the car up in May this year. Will keep an eye on it over the coming months to see if it was a one off or an ongoing problem.
 

·
Registered
Joined
·
136 Posts
had this with my old focus,


you could have the clock right, but not the date, or vice versa



never managed to sort it out, so traded it in with this fault



luckily my K is ok
 
1 - 8 of 8 Posts
Top