Ford Kuga Owners Club Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi, my front wipers stopped working both on auto and manual.
After trying to locate the fuse I can only locate the Autowiper fuse.
Is there a separate fuse/relay just for the front wipers?
Any other ideas apart from wipers motors?
Rear one works as do the water pump.
Thanks
 

·
Registered
Joined
·
6,569 Posts
They are stepper motors and are controlled from the Body Control Module (part of the passenger fuse box) and are synchronised with each other. They may require resetting.
 

·
Registered
Joined
·
6,569 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #6
I got this fixed, not long after posting here.
You have two wiper motors, the driver's side is the main motor. When this goes, the other .will stop.
Got a replacement of eBay, £30, near enough new and local garage to refit it.
£60 total.

Ford garage were quoting around the £300 mark.

Ford also said they would need to reprogram the wipers to make sure they are aligned. Wasn't necessary.
 

·
Registered
Joined
·
6,569 Posts
Great news, great price too. OOI, how old is your Kuga?
 

·
Registered
Joined
·
1 Posts
I'm getting this problem on my 2015, wiper stick and stop at random. The pivot and pline are fine and can here the motors going. Give them a little push and they start again. Any ideas?
 

·
Registered
Joined
·
1 Posts
Mine stopped working the other day after I washed the car, even when I have the engine running the wipers are loose and have no power to them. Has anyone else had these problems? Thanks Mike
 
1 - 9 of 9 Posts
Top