Ford Kuga Owners Club Forums banner

1 - 6 of 6 Posts

Registered
Joined
11 Posts
Discussion Starter · #1 ·
On my plug in hribrid, If I choose EV mode, instead of my default Calm Screen it always shows EV Now, with a prompt to press OK to enable engine.

This is really annoying. I've chosen eV mode because I don't want to use the engine.

Anyway to disable this screen or at least make it disappear after say 10s?
 

Registered
Joined
6 Posts
I have the same problem. I want the dash to display Trip1 every time I start the car. Has anyone figure this out? Is it possible? 馃槀
 

Registered
Joined
6 Posts
Don't press OK but press the down arrow button. Removes the message.
Thanks. This works. But still, I want my dash to revert the last settings used. Now, I have two press a button all the time I start the car.
Same happens with the Lane keeping system. I want this off, but every time I start the engine, it is still on.
 

Registered
Joined
423 Posts
Thanks. This works. But still, I want my dash to revert the last settings used. Now, I have two press a button all the time I start the car.
Same happens with the Lane keeping system. I want this off, but every time I start the engine, it is still on.
Lane Assist has to be on by default on restart now, part of the type approval / NCAP since 2020. Luckily on the Kuga it is just a single button press, on some cars it is buried in a menu somewhere.

Our car always displays trip 1 on startup and remembers it. To be honest we don't use EV Now, as it runs full electric anyway unless you really press the accelerator hard. Make sure you have grade assist turned off or that starts the engine up too often.
 

Registered
Joined
6 Posts
Thanks. Good to know about the Grade Assist. I am comuting every day about 20 Km each way and so far I have only driven it on EV now mode. Even if the speed is 130 km/h the engine is not turned on. I will try EV auto to see the difference.
 
1 - 6 of 6 Posts
Top