Ford Kuga Owners Club Forums banner
1 - 20 of 42 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
guys my 59 plate kuga has the dab stereo. on saturday when i turned the car on it displayed no audio and freezed. i took it to the ford garage And they reckon it had re set itself and i would need to enter code after one hour anyway later that day it stated working has any one else had this problem?
 

·
Registered
Joined
·
2,825 Posts
Hi Banners. Read somewhere that some KOC members currently awaiting delivery have had there delivery dates pushed back due to the factory havingproblems securing DAB radios from Sony. Some have speculation about that perhaps Sony have identified a problem and are in the process of doing a, Fix. My opinion of the SonyDAB is not good, for me personally, mainlydue to poor reception (signal strength) it's not aperfect solution but is far better in FM mode, DAB for me personally it's, pointless.
 

·
Registered
Joined
·
84 Posts
I had DAB in my last car (a vectra) and the Sony unit isn't patch on it. poor reception, no track info and takes ages to change stations. If i had the Sony unit first, I wouldn't have been bothered about DAB, but because the vectra unit was so good it was on my must have list.
 

·
Registered
Joined
·
855 Posts
I have a 09 plate. After about 3 weeks the DAB stereo froze and i just had a clicking coming from the speakers. Tried turning off and on a couple of times but without success. After about an hour i drove to the dealership. Turned the engine off to go into dealership. Thought to do one last check and it worked. Asked the service guy about it but he said thet'd not had any problems with them. Then a couple of months later the bluetooth went pete tonge which i think is all linked in.
 

·
Registered
Joined
·
2,825 Posts
Thanks! Glad I am not on my own on this one.Curiously some members experience is totally different, and full of praise, I suspect itdepends onthe areaslocal transmitter, generally South Manchester signal strength is very poor. Bob.
 

·
Registered
Joined
·
8 Posts
hi

i had my 59 plate with sony DAB for a week, exactlly the same thing happened it froze!!!
i rang the dealer they couldnt look at it for a week i tried switching the radio on and off it did nothing i rang the dealer back give them what for then they said bring it in within the hour ,so i started it up to go and whey hey the radio worked no problems since!!!!!!!!
 

·
Registered
Joined
·
1 Posts
Just picked up our new 2wd titanium kuga in vision blue this morning - my wife has just been out and come back saying that the radio is not working - case of the clicking speakers. Had a quick look on the forum and saw that others have had the same problem. She unpaired her phone from the bluetooth connection and hey presto radio springs back into life. Paired it back up again and all seems ok for now. Looks like JB1 is on to it citing the Bluetooth as culprit.
 

·
Registered
Joined
·
13 Posts
Does anyone know what this symbol on the radio is for.it's like a square with 4 smaller ones around it.I think it might be for stereo but it's not shown in the book.Channel sounds alter greatly when it's on but constantly drops in and out on both dab and fm
 

·
Registered
Joined
·
328 Posts
One interesting thing relating to all these DAB problems - they all seem to affect the single disc versions - even on other Ford models, no one seems to have a single issue with the 6 disc version
 

·
Registered
Joined
·
48 Posts
Kuga Jon said:
One interesting thing relating to all these DAB problems - they all seem to affect the single disc versions - even on other Ford models, no one seems to have a single issue with the 6 disc version
I have the six disc version, and just nipped out and found the radio clicking at me. I also have the BT voice system

I turned it on and off, and the still clicking. I got out and locked the car......still clicking.

Came home bugged that I would be spending a few more hours sat in my Ford dealer, and found this thread.

As I had not taken my phone with me last time I decided to take it out to the car to see if it was syncing. Jump in, turn the stereo on, phone beeps to say it's connected. Iron Maiden blast from the speaker......stereo fixed.

Looks like it throws the odd wobbler if it can't find the phone.
 

·
Registered
Joined
·
115 Posts
I have the single CD Sony DAB unit, I live in the Midlands but travel down to Somerset and over to Lincolnshire quite a bit, never had any of these problems. What I do get it mini-cabs and especially their base stations completely blotting out the radio signal when I drive past. One in particular causes the problem twice a day.
 

·
Registered
Joined
·
439 Posts
Never use mine on DAB, its crap.


Its also started telling me theres a problem with the cd player, sometimes it plays cds other times it takes a hissy fit and refuses to play them. Comes up CD ERROR or PLAYER ERROR. What fun! Not taking it to dealer, its getting changed soon so will put up with it until then
 

·
Registered
Joined
·
48 Posts
I have to say though, I use the DAB a lot and think it's great.

It goes completely in rural areas, but along the M4 corridor it works great.
 

·
Registered
Joined
·
2,825 Posts
Sony DAB. Cut's out continually withthis message PHONE.Call in progress. Dealer workshop manager
fortunately Ican spot the stupid and totally clueless within seconds, and when he told me he could nota reason for this, I tend to believe him.
 

·
Registered
Joined
·
702 Posts
Bob, just wondering how many of the members, who are having problems, have the "Bluetooth" accessory fitted. I do not have bluetooth and have a single CD Sony player and while it is not the best, I have not had any issues with it.


Just a thought
 
1 - 20 of 42 Posts
Top