Ford Kuga Owners Club Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I recently purchased a Ford Kuga Mk2 2.0 Ecoboost and I love it. I just have one intermitant problem. The Cruise Control does not activitate everytime I want it to. Sometime it goes into the standby mode and works fine and other times not at all. The Limit function seems to work fine everytime.

Anyone else with this problem and potential fix?
 

·
Super Moderator and Mr Grumpy
Joined
·
6,779 Posts
Have you got adaptive cruise control on yours. If so the sensor may be in the front grill and can get damaged.
 

·
Update Ninja
Vignale 2019, Platinum White
Joined
·
3,817 Posts
Is this happening at all speeds, what is the minimum speed you’ve tried to set it
oops!….finger stammer
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Is this happening at all speeds, what is the minimum speed you’ve tried to set it
oops!….finger stammer
Hi RonnieM,

It actually doesn't get to the "Set" menu. On my model, you first need to press the cruise control button to get into "cruise standby mode" and then press the "Set+" or "Set-" buttons to select cruise speed. I cannot get into the cruise standby mode and therefore the Set+/- buttons dont do anything.

Cruise Standby mode can be activated or deactivated at anytime or speed as long as the engine is running. Same goes for the Limit Speed Standby. I've activated it many times even at standstill although the minimum cruise Set speed is 30kph.

I'm completely stumped as to why it sometimes works and sometimes doesnt...so stumped that I finger stammer🤣
 

·
Update Ninja
Vignale 2019, Platinum White
Joined
·
3,817 Posts
Is this happening at all speeds, what is the minimum speed you’ve tried to set it
Hi RonnieM,

It actually doesn't get to the "Set" menu. On my model, you first need to press the cruise control button to get into "cruise standby mode" and then press the "Set+" or "Set-" buttons to select cruise speed. I cannot get into the cruise standby mode and therefore the Set+/- buttons dont do anything.

Cruise Standby mode can be activated or deactivated at anytime or speed as long as the engine is running. Same goes for the Limit Speed Standby. I've activated it many times even at standstill although the minimum cruise Set speed is 30kph.

I'm completely stumped as to why it sometimes works and sometimes doesnt...so stumped that I finger stammer🤣
Your right in what you’re saying, I would suspect a faulty switch not activating standby mode
 

·
Super Moderator and Mr Grumpy
Joined
·
6,779 Posts
Agree with above. Definitely sounds like the switch if it doesn't switch on to standby. I would try a second hand switch from a breakers yard of if the car came with warranty then take it back to the garage and get them to fix it.
 
  • Like
Reactions: murcod

·
Moderator
2016 Kuga Titanium 2.0l EcoBoost
Joined
·
3,517 Posts
Hopefully it's not the "clock spring" at fault?
 

·
Registered
Joined
·
1,605 Posts
Could be the switch on the brake pedal.
 
1 - 10 of 10 Posts
Top