Ford Kuga Owners Club Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi All.
ABS / Traction warning lights have just come on and no hill start assist available. Also if i try and de-activate traction control it just activates again.
OBD scanner showing no faults. 2015 2lt Titanium Diesel. ?
Any suggestions/pointers would be very much appreciated.
 

·
Super Moderator
Joined
·
1,941 Posts
Hi All.
ABS / Traction warning lights have just come on and no hill start assist available. Also if i try and de-activate traction control it just activates again.
OBD scanner showing no faults. 2015 2lt Titanium Diesel. ?
Any suggestions/pointers would be very much appreciated.

Any work on the brakes recently?


Pop it into a good independent and get it up on a ramp, I would initially check for any loose or broken wires to the sensors.
 

·
Registered
Joined
·
347 Posts
Hi All.
ABS / Traction warning lights have just come on and no hill start assist available. Also if i try and de-activate traction control it just activates again.
OBD scanner showing no faults. 2015 2lt Titanium Diesel. ?
Any suggestions/pointers would be very much appreciated.
If you have a multimeter handy, you can test each sensor individually by unplugging the wires and testing the 'resistance' (ohms - Ω) between the two sensor wires.... a working sensor should be around 1000-1200 ohms.. a faulty sensor will be open circuit (OC) or in the region of mega ohms... if you identify a faulty unit, buy online and replace....
 

·
Registered
Joined
·
2,417 Posts
What sort of OBD2 scanner did you use? You might need to use a Ford specific scanner as Ford use a non standard protocol.



The free program "ForScan" with a suitable Ford Medium Speed Canbus OBD2 interface is probably the best option.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Thanks for taking time to reply guys. Once the weather improves I will get out and have a look at sensors.
 

·
Registered
Joined
·
1,262 Posts
Hi mate did you find out what was wrong with this as mine is doing it this morning
I don't think you'll get a reply as the OP registered and only made the 2 posts.
Try following the advice given here on this thread, it's good relevant advice.
 

·
Registered
Joined
·
2 Posts
Hi everyone, I have the ABS/Traction warning lights appearing, they arent on at first then there is a jolt and they appear, we have changed the discs and pads and checked for lose wires. I had a ford kuga 2010 diesel and it also seems like every so often when he press the brake pedal it sounds like it grinds, any ideas on what to do next. We are also trying to locate a hardcopy of the manual
 

·
Super Moderator
Joined
·
1,941 Posts
Hello Gaynor and welcome to the forum.

I would double-check for any loose or pinched wires (quite common after a disc/pad change).

Failing which, find a good local independent garage to read any fault codes that may be thrown up. They will normally only make a modest charge to read the codes and most will waive this if they then do any work as a result.
 

·
Registered
Joined
·
2 Posts
Hello Gaynor and welcome to the forum.

I would double-check for any loose or pinched wires (quite common after a disc/pad change).

Failing which, find a good local independent garage to read any fault codes that may be thrown up. They will normally only make a modest charge to read the codes and most will waive this if they then do any work as a result.
Thanks, it was happening before we changed the pads and discs as we thought it was that, we will check it on the computer as you’ve mentioned
 
1 - 10 of 10 Posts
Top