New Posts New Posts RSS Feed - Instrument Cluster advice
  FAQ FAQ  Forum Search   Register Register  Login Login


Welcome to the Ford Kuga Owners Club Forums!

Instrument Cluster advice

 Post Reply Post Reply
Author
Ant View Drop Down
Senior Member
Senior Member


Joined: 04 Nov 2015
Location: 2mins off junc2
Status: Online
Points: 509
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ant Quote  Post ReplyReply Direct Link To This Post Topic: Instrument Cluster advice
    Posted: 13 Nov 2017 at 12:26pm
We have the IC u1900-20 fault code always have had since the intermittent morning non start issue which started last year....

Now i was talking to diesel spec guy today as recommended by a lad i know who deals in motors as they get it a lot with the focus..

The specialist after a long conversation about our problem said that the issue is the instrument cluster panel not letting the kuga start due to the immobiliser.....

I told him we had the IC repaired on the dry joints etc and how the connect clip on the back to the loom is or was loose at the time of the repair....

The guy said its self explanatory then if you have an error code for the IC unit that is your problem all a long....
Its not releasing the immobiliser...

He said take out the IC unit and unclip the loom then try and start up the kuga..

If it starts its the IC unit..
Or
If it does not start its not the IC unit.....

Now i always thought that without the IC unit connected it wouldnt start anyway....
Is he talking A load of BS......

Edited by Ant - 13 Nov 2017 at 12:28pm
2010 Zetec 2ltr TDCI 2WD SUV frozen white
Back to Top
Sponsored Links


Back to Top
Ozekuga View Drop Down
Senior Member
Senior Member
Avatar

Joined: 07 Jan 2017
Location: Adelaide
Status: Offline
Points: 543
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ozekuga Quote  Post ReplyReply Direct Link To This Post Posted: 14 Nov 2017 at 8:06am
I've no idea but he may know a lot more about Kugas than I do, so I would try it, what harm can it do?
2016 Kuga Trend MY16.5
2.0L Ecoboost 242 ps AWD with Sync 2 8" touch screen
LED DRL's
Back to Top
hillybilly View Drop Down
Senior Member
Senior Member
Avatar

Joined: 11 Oct 2014
Location: perthshire
Status: Offline
Points: 613
Post Options Post Options   Thanks (0) Thanks(0)   Quote hillybilly Quote  Post ReplyReply Direct Link To This Post Posted: 14 Nov 2017 at 9:26am
If it is your immobiliser it won't even try and start
Back to Top
Ant View Drop Down
Senior Member
Senior Member


Joined: 04 Nov 2015
Location: 2mins off junc2
Status: Online
Points: 509
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ant Quote  Post ReplyReply Direct Link To This Post Posted: 14 Nov 2017 at 9:33am
Mmmmm its an idea as i need to remove the cluster for the part number....
As i have found an official ford outlet that sells parts cheaper than the dealership..

Also i was reading an article with an auto electrian on the internet and the IC u1900-20 can cause the non starts...

The ford outlet is £200 cheaper than buying directly from the dealership so it makes sense to buy the cheaper one as that £200 will pay to have the keys recoded etc.....
2010 Zetec 2ltr TDCI 2WD SUV frozen white
Back to Top
tractorboy View Drop Down
Senior Groupie
Senior Groupie


Joined: 24 Jan 2017
Location: Suffolk, UK
Status: Offline
Points: 197
Post Options Post Options   Thanks (0) Thanks(0)   Quote tractorboy Quote  Post ReplyReply Direct Link To This Post Posted: 14 Nov 2017 at 11:08am
I really think you are barking up the wrong (and expensive) tree here.  If it was an immobiliser issue then it wouldn't start at all.

Bob
2013 Kuga Titanium X 2.0 TDCI 163PS Powershift AWD.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 10.11
Copyright ©2001-2012 Web Wiz Ltd.